Troubleshoot tuition fees not posting during registration for the By Session Dates Billing Cycle

Issue/Question


Why are fees not posting upon registration for some students? The class is registered for, but there is not a fee being posted to their account.

Environment


Jackrabbit application, Class record, Drop-down List Editor

Cause


The Tuition Billing Cycle in the Class record is set to By Session Dates, and the start/end date of the class falls outside the end date of the Session in the Drop-down List Editor.

Resolution


When the billing cycle in the Class record is set to By Session Dates, the start/end dates of the session in the Drop-down List Editor must include the start/end dates of all classes assigned to that session. If class dates fall outside the session’s date range, Jackrabbit will not automatically post fees, even if prorating is enabled.

To fix this:

  1. Go to the Gear icon > Settings > General > Drop-down Lists (left menu) > Session (left menu).
  2. Locate the session assigned to the affected class(es).
  3. Check that the session’s Start and End dates include all start/end dates for classes assigned to that session.
  4. If necessary, update the session dates to include the class dates fully.
  5. Click Save Changes.
  6. Manually post the tuition fees for any registrations that have already occurred.