Troubleshoot automation task not posting monthly tuition to all families

Issue/Question


Our monthly tuition was supposed to post to all actively enrolled families’ accounts using an automation task, but it didn’t. Only some families had fees posted. Why did this happen and how do I prevent it from happening again?

Environment


Jackrabbit application, Transactions > Automation > Task Management

Cause


The date range in the automation task was set incorrectly for duplicate detection, which caused the system to skip posting tuition fees for families whose fees did not fall within that range. 

Resolution


Automation tasks cannot be edited.

To prevent the issue from happening again:

  1. Go to the Transactions menu > Automation > Task Management.
  2. Delete the existing automated task with the incorrect date range.
  3. Create a new automated task with the correct date range for duplicate detection.