Fix classes in a new session that aren't showing online

Issue/Question


Why aren't the classes in our new session showing up online?

Environment


Jackrabbit application, Class record > Summary tab, Classes > Edit All Classes

Cause


The Display in Online Class Listings, Allow Online Registration, and Allow Portal Enrollment settings were not enabled on the Summary tab of the new session's Class records.

Resolution


Classes are only available online when their visibility and enrollment settings are enabled in the Class record.

To enable these settings for all of the classes in the session at once: 

  1. Go to the  Classes menu > Edit All Classes.
  2. From the Search Criteria, select the Session and click Submit.
  3. On the Edit Classes page, click Show All if the session has more than 50 classes.
  4. In the yellow Global Change row, set Display in Online Class Listings?, Allow Online Reg?, and Allow Portal? settings to Yes.
  5. Click Save Changes.

The session's classes are now available online.